Intellisense wrong parameter info

Sysprogs forums Forums VisualGDB Intellisense wrong parameter info

This topic contains 3 replies, has 2 voices, and was last updated by  support 1 week, 1 day ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #24963

    MystikReasons
    Participant

    I have a problem with the informations showed for the parameters.

    In my header of the function I have the following infopoints: (@brief, @param and @retval)

    See my screenshot for my function info and the structure of it.

    If I now call the function it looks like this (see screenshot #2)

    Is there a way to say it should take the informations from @param for the parameter informations?

    Attachments:
    You must be logged in to view attached files.
    #24966

    support
    Keymaster

    Hi,

    It looks like the ‘*’ frame around the comment is interfering with the comment parsing logic.

    Please ensure that the line containing the ‘@param’ comment does not have any other characters (other then spaces) in front of the @param part and VisualGDB will handle it correctly.

    #24978

    MystikReasons
    Participant

    I tried your suggestions but without any success. It still only displays the @brief informations.

    Is it because I’ve created the header with /* */ instead of ‘//’?

    And would it be possible to add a feature maybe inside Tools/Options/VisualGDB/IntelliSense where you can enter characters which should be ignored?

    That would be a huge relief because with the “*” it looks much cleaner in Visual Studio.

    See “screenshot #1” for the header which you suggested (withou ‘*’).

     

    Update: Now the parameter infos are weirder. It now displays the @brief informations and the @retval info instead of the @params. See screenshot #2

    And the function info is also weird now: It first displays the @brief informations then the @retval info and first at the end the @params info (see screenshot #3)

    Attachments:
    You must be logged in to view attached files.
    #24984

    support
    Keymaster

    Please ensure that the parameter names after @param are not wrapped with any ‘<>’, e.g.:

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.