Init mode failed (unable to connect to the target)

Sysprogs forums Forums VisualGDB Init mode failed (unable to connect to the target)

This topic contains 1 reply, has 2 voices, and was last updated by  support 1 week, 5 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #28125

    carneytom1981
    Participant

    Hi,

    I’ve recently posted in another thread about a problem getting my STM32VLDiscovery board running

    (https://sysprogs.com/w/forums/topic/installing-st-link-drivers-on-discovery-board/)

    I have now reached a point where the device appears correctly in the device manager. However I am now getting a whole new error.  When I try to start remote debugging I get

    init mode failed (unable to connect to the target)

    When I click ‘view gdb stub log’ I get the attched log data

    In the GDB Session window of Visual Studio it says

    :49865: No connection could be made because the target machine actively refused it

    Any advice on how to proceed?

    Thanks

     

    Attachments:
    You must be logged in to view attached files.
    #28127

    support
    Keymaster

    Hi,

    If this is the same board you mentioned before (where you had to hold the reset button in order to connect using the ST-Link utility), please make sure you do the same with VisualGDB. Please also try using the “connect under reset” checkbox.

    If nothing helps, please try checking if the board works when using the Eclipse-based STM32 IDE, that also uses OpenOCD.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.