Indent case labes in VisualGDB

Sysprogs forums Forums VisualGDB Indent case labes in VisualGDB

This topic contains 5 replies, has 2 voices, and was last updated by  kaworu 1 month, 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #30216

    kaworu
    Participant

    Hello.

    Question, where in visualgdb I can find code formatting option option called “indent case labes” in visual studio? Or better it’s possible to give control over code formatting to visual studio engine completely?

    Attachments:
    You must be logged in to view attached files.
    #30218

    support
    Keymaster

    Hi,

    No problem, please see the following page for a detailed explanation of formatting-related settings: https://visualgdb.com/documentation/intellisense/

    #30219

    kaworu
    Participant

    Except – It doesn’t work. Switched to “Regular Intellisense” (first screenshot), restarted VS, reloaded project, Ctrl+K,D and it still doesn’t follow VS’s formatting settings (see screenshots). Confirmed that on Clang Intellisense Diagnostic Console “Native VC++” is selected.

    Attachments:
    You must be logged in to view attached files.
    #30222

    support
    Keymaster

    Most likely, you have selected an incompatible combination of settings at some point.

    We can help you understand what is going on if you could share the steps for reproducing the problem from scratch per our problem reporting guidelines. Please make sure the steps include entire uncropped screenshots of all the relevant windows as shown in the “screenshots” section of the guidelines.

    #30223

    kaworu
    Participant

    Funny something new happened, I went to the options, Tools -> Options, Text Editor -> C/C++ (VisualGDB) -> Formatting Engine, changed “Default Formatting Engine” to “SysProgsFormat”, restarted VS, and now Ctrl+K,D works differently, but still not correctly – see attachment.

    So for now my conclusion is, as follows:

    • If Text Editor -> C/C++ -> Formatting -> Indentation, option “indent case labels” is selected
    • And in Text Editor -> C/C++ (VisualGDB) -> Formatting Engine, “Default Formatting Engine” is set to “SysProgsFormat”, then indentation is made before case label – this is expected – and after case label – this is wrong;
    • If in Text Editor -> C/C++ (VisualGDB) -> Formatting Engine, “Default Formatting Engine” is set to “Clang format”, then indentation is not made neither before nor after case label;

    Also changing this options requires reloading the project, i would expect this change to be taken into account right away or at lest would be nice to have info somewhere, “changing this option requires restart”, or something.

    Attachments:
    You must be logged in to view attached files.
    #30225

    kaworu
    Participant

    Oh, and my indentation settings from VS.

    Edit: attached wrong screenshot, newer one is correct.

    • This reply was modified 1 month, 2 weeks ago by  kaworu. Reason: Wrong screensot
    Attachments:
    You must be logged in to view attached files.
Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.