How to use armclang.exe instead of armasm.exe

Sysprogs forums Forums VisualGDB How to use armclang.exe instead of armasm.exe

This topic contains 9 replies, has 2 voices, and was last updated by  support 1 month, 1 week ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #29803

    DanielFuchs
    Participant

    Hi,

    we are using KEIL MDK 5.33 PRO, VisualGDB 5.5R4 (build 3920) and Visual Studio 2019 Pro at the moment.

    For testing i’ve build an project via the “Embedded Project Wizard” for a STM32H743XIH6 and copied our existing files. Our startup-code is in a assembler file with gnu syntax and so i would like to use armclang.exe for it.

    Our toolchain is “Keil ARMClang (Stand-alone) Version 6.15”.

    How can i tell VisualGDB to use armclang.exe instead of the legacy armasm.exe?

    Kind regards

    Daniel

    • This topic was modified 6 months, 1 week ago by  DanielFuchs.
    Attachments:
    You must be logged in to view attached files.
    #29814

    support
    Keymaster

    Hi,

    No problem, please try this build: VisualGDB-5.5.104.3944.msi

    You can now configure VisualGDB to treat assembly files as C files (i.e. pass them to armclang.exe and not remove C/C++-specific flags) by adding the following element inside a relevant PropertyGroup in your .vcxproj file:

    #29815

    DanielFuchs
    Participant

    Hi,

    that’s a nice solution. The complete code compiles 🙂
    Now i have to test the different debug probes we have.

    Thank you for your quick help!

    Kind regards
    Daniel

    #29817

    support
    Keymaster

    Hi,

    Good to know it works. If you encounter any other issues, feel free to start another thread.

    #30567

    DanielFuchs
    Participant

    Hi,

    I’ve updated to version 5.5R5 (build 4124) because the window popped up and i didn’t think about it.
    Now it isn’t compiling anymore.
    Was the feature removed or did the parameters change?

    I think at first i have to downgrade to the version mentioned above.

    Kind regards
    Daniel

    • This reply was modified 2 months ago by  DanielFuchs.
    #30575

    support
    Keymaster

    Hi,

    The newer builds usually include all the fixes from the older builds (unless they have been removed due to problems with other functionality), hence it should work.

    The problems are likely caused by something else. Please feel free to share the details on the errors you get (and also renew your support here as it has recently expired) and we will help you get it working.

    #30699

    DanielFuchs
    Participant

    Hi,

    we’ve renewed my support 🙂

    I get the error from armasm.exe:
    Failed to compile startup.s. armasm.exe exited with code 8

    But i still want to use armclang and have the following line in my .vcxproj file
    <TreatAssemblyFilesAsCFiles>true</TreatAssemblyFilesAsCFiles>

    Kind regards
    Daniel

    #30701

    support
    Keymaster

    Thanks for renewing your support. The option should be available in VisualGDB 5.5R5. If it doesn’t work, please try the latest development build here: VisualGDB-5.6.1.4153.msi

    #30708

    DanielFuchs
    Participant

    Hi,

    as i mentioned before i’ve VisualGDB version 5.5R5 (build 4124).

    I will try the development build.
    Edit:
    Now i have version 5.6(Beta 1, build 4153) and it compiles the assembler files with armclang again.
    (Visual Studio Professional 2019 Version 16.10.1)

    Kind regards
    Daniel

    • This reply was modified 1 month, 1 week ago by  DanielFuchs.
    #30715

    support
    Keymaster

    Good to know it works. If you encounter further issues, feel free to get back to us.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.