Getting errors building Qt application for Pi3

Sysprogs forums Forums VisualGDB Getting errors building Qt application for Pi3

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by  support 1 month, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #31848

    bossssie
    Participant

    Hi,

    I am developing a project for the Raspberry Pi 3B. I have made a GUI in Qt Designer and a bit of C++ code. This all went great until it didn’t. For some reason I cannot build the project anymore, and I can’t find out what changed.

    I now get a “AutoMoc subprocess error,┬áThe moc process failed to compile.” Detailed log is in the attachment

    What I tried:
    -restoring from git to previous working solution
    -New project
    -Different PC with clean install of VisualGDB and Toolchain
    -Clean raspberry pi image

    #31849

    bossssie
    Participant

    I now tried installing it with Raspi Os Buster and that seems to work again. But would like to get it working with bullseye

    #31850

    support
    Keymaster

    Hi,

    Different versions of the Raspberry Pi OS come with different Qt versions. Hence, if your application was developed with an older Qt, it may need to be adjusted in order to work on the latest one.

    You might be able to get some clues on the Qt forums, as other users upgrading to a newer Qt have likely experienced similar issues.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.