-gdb-version taking too long to complete

Sysprogs forums Forums VisualGDB -gdb-version taking too long to complete

This topic contains 5 replies, has 2 voices, and was last updated by  ews 3 weeks, 6 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #34606


    Whenever I start a new hardware debugging session I get the message “The following GDB command is taking too long to complete:  -gdb-version” and there is a 20 second wait before I can proceed. This just started happening with the last Visual GDB update I installed. Uninstalling/re-installing Visual GDB has not helped. Any suggestions as to what to try next?


    You must be logged in to view attached files.



    The -gdb-version is the first command sent by VisualGDB to GDB. If it times out, it means that the GDB executable takes that long to initialize. You can try running it manually with the same arguments used by VisualGDB and see if there is any pattern.

    The delay can also be caused by your antivirus or could be related to the latest ARM toolchain that takes considerably longer to load some symbols. If it only happens for embedded ARM projects and reverting to an older toolchain fixes it, please let us know and we will investigate it more.



    Thanks for the response. I tried running GDB from the command line and it seems to be taking a long time  on the step

    ~”Reading symbols from <project name>…\n”

    where it hangs up for around 20 seconds, same as when I was running it via VisualGDB. After that I could interact with GDB via the command line and it responded quickly.

    I have no idea if this is related but there were some warnings while re-building the project that I don’t recall seeing before:

    Linking ../VisualGDB/Debug/fwip…
    c:/sysgcc/arm-eabi/bin/../lib/gcc/arm-none-eabi/12.2.1/../../../../arm-none-eabi/bin/ld.exe: c:/sysgcc/arm-eabi/bin/../lib/gcc/arm-none-eabi/12.2.1/thumb/v7e-m+fp/hard\libc_nano.a(libc_a-fstatr.o): in function `_fstat_r’:
    fstatr.c:(.text._fstat_r+0xe): warning: _fstat is not implemented and will always fail
    c:/sysgcc/arm-eabi/bin/../lib/gcc/arm-none-eabi/12.2.1/../../../../arm-none-eabi/bin/ld.exe: warning: ../VisualGDB/Debug/fwip has a LOAD segment with RWX permissions

    I’ll see if I can change the ARM toolchain and get a different outcome next.




    Thanks, this looks like a known issue of the new toolchain. We are not aware of any workarounds yet, so if it is affecting you, please consider downgrading it until we figure out a better solution.

    The warning message you mentioned is described here: https://visualgdb.com/documentation/semihosting/#notimpl



    Update: We have run some additional tests and it looks like the problem only happens with the gdb binaries shipped with the original ARM toolchain. We built the latest gdb 13.2 from sources, and it manages to load the symbols instantly, just like the older gdb versions.

    We have published an updated ARM toolchain that replaces the GDB binary with the one we built. You can install it via VisualGDB Package Manager or directly from here: arm-eabi-gcc12.3.1.exe



    I tried out the updated toolchain and it worked perfectly. Thank you for the excellent support!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.