ESP32 Needs toolchain update

Sysprogs forums Forums VisualGDB ESP32 Needs toolchain update

This topic contains 1 reply, has 2 voices, and was last updated by  support 2 weeks, 2 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #28777

    angel
    Participant

    used by visualgdb esp-2019r2-8.2.0, but there is a new version esp-2020r2-8.2.0

    xtensa-esp32-elf-gcc.exe: error: unrecognized command line option ‘-mfix-esp32-psram-cache-strategy=memw’; did you mean ‘-mfix-esp32-psram-cache-issue’?

    #28778

    support
    Keymaster

    Hi,

    According to our records, your support period has expired. In order to continue receiving support, please renew your key here: https://sysprogs.com/splm/mykey

    P.S. We do release toolchain updates regularly. However, if you decide to not renew your support and keep using an old unsupported version of VisualGDB, the new toolchains may indeed not work with it, as the internal changes to ESP-IDF often require updates on the VisualGDB side as well.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.