ESP32 5.2.0/7.10/r6

Sysprogs forums Forums VisualGDB ESP32 5.2.0/7.10/r6

This topic contains 1 reply, has 2 voices, and was last updated by  support 1 week, 5 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #12638

    jsmith
    Participant

    Unusable.

    I’m trying to compile and debug project based on external ESP-IDF (like decribed there https://visualgdb.com/tutorials/esp32/esp-idf/, with one addition – project is based on ESP-IDF-3.0 ‘current’ ([toolchain]/etc/profile was modified to point to my copy of ESP-IDF).

    Compilation – no issues. ‘make flash’ (via serial port) also works.

    Flashing and debugging via JTAG (FTDI2232H-based board) – does not work. Seems like ESP32 bootloader is corrupted. No idea what is happening.

    Tried to reinstall r6 from scratch – now it does not see OpenOCD – says ‘opencod (unavailable)’.

    r1-r5 worked more or less.

    #12642

    support
    Keymaster

    Hi,

    The new r6 build fixes the FLASH memory type/size settings. Perhaps your device has a smaller FLASH memory than your settings specify?

    If not, please try changing any settings on the Debug Settings page of VisualGDB Project Properties and then manually set the ‘PatchBootloader’ field in the .vgdbsettings file to ‘false’. If this solves the problem, please try switching the FLASH mode to DIO and reducing the FLASH size.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.