Error with Kernel-Mode Connections

Sysprogs forums Forums VisualDDK/VirtualKD discussion Error with Kernel-Mode Connections

This topic contains 3 replies, has 2 voices, and was last updated by  support 12 years, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #141

    Anonymous
    Participant

    I had configured it, but incorrectly pointed it to the Debugging Tools for x64 instead of x86.
    Now, when i try to use the kernel-mode connect for 1394, it comes back with “Unable to connect to ‘1394://1’. One of the library files needed to run this application cannot be found”

    I tried to uninstall and reinstall, but it leaves residue in the system, so it picks up the old folder instead of asking me again where it is.

    Any assist is appreciated as I’m interested to see how this might run.

    #1281

    support
    Keymaster

    Please try raw:// prefix, as described here:
    viewtopic.php?f=4&t=378

    #1282

    Anonymous
    Participant

    Answer is to go into the registry under:
    HKLMSOFTWAREBazisSoftVisualDDKDDKDebuggerParameters (add Wow6432Node before BazisSoft if you are 64 bit)

    Find the “DebugToolsPath” and make sure its set to the correct folder.
    C:Program Files (x86)Debugging Tools for Windows (x86)

    It would be good to have it not allow the selection of the 64 bit debug dll (just try to load it under 32 bit context at selection and if it fails, dont allow)
    Or remove that key when you uninstall (as it was being left behind as residue after uninstall).

    #1283

    support
    Keymaster

    You can always change the DLL path by selecting Tools->VisualDDK Options in Visual Studio.
    BTW, does the 1394:// prefix work correctly?

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.