Disable Custom CMake Macro Warning?

Sysprogs forums Forums VisualGDB Disable Custom CMake Macro Warning?

This topic contains 1 reply, has 2 voices, and was last updated by  support 1 month, 1 week ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #33033

    Noah
    Participant

    Hello,

    I have a project which uses ZephyrOS and CMake. I am using VisualGDB as my “IDE.” Everything is working great, except there is a warning that appears at the top of any source code file I am editing. See attached file “custom_macro_warning.png.” I am aware that there are complications regarding VisualGDB’s CMake smarts interacting with Zephyr’s quite complex build system which uses CMake and Python. I don’t need any of these intelligent CMake features, as I only ever edit my CMake files manually. I am wondering if there is a way to tell VisualGDB’s intelligent CMake subsystem to ignore certain targets, or to suppress this warning altogether.

    The reason I ask is because every time I click into an editor window, this warning appears and shifts all lines down which causes a full line to be highlighted in the editor. It’s one of those little annoyances that really adds up over time.

    Thank you for the help,

    Noah

    Attachments:
    You must be logged in to view attached files.
    #33041

    support
    Keymaster

    Hi,

    Sure, you can disable this behavior via the Detect Ambiguous Target Definitions option. See this page for the exact location of the option in the latest VisualGDB version.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.