Deploying OpenCV binaries

Sysprogs forums Forums VisualGDB Deploying OpenCV binaries

This topic contains 1 reply, has 2 voices, and was last updated by  support 1 month, 1 week ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #27070


    I am using this tutorial to cross compile OpenCV to Raspberry Pi:

    I am nearly thru the tutorial, but  step # 21 is not working for me: “Once the build completes, right-click on the project node in Solution Explorer and select “Install all targets”.  Specifically, the Build Target seems to work properly to [100%],  and the installation seems to work fine:

    “Install the project…”
    — Install configuration: “DEBUG”
    — Up-to-date: C:/projects/LinuxProject5/LinuxProject5/../../../opencv/VisualGDB/Debug/install/share/OpenCV/licenses/opencl-headers-LICENSE.txt

    — Up-to-date: …..

    However, when VisualGDB attempts to upload to /usr/local “Permission is denied” for all files/folders:

    Uploading C:/projects/LinuxProject5/LinuxProject5/../../../opencv/VisualGDB/Debug/install to /usr/local…
    VisualGDB: Warning: Stderr line received ‘tar: bin/opencv_annotation: Cannot open: Permission denied’
    VisualGDB: Warning: Stderr line received ‘tar: bin/opencv_createsamples: Cannot open: Permission denied’

    VisualGDB: Warning: ….

    I have double checked the configured deployment settings on the CMake page of VisualGDB Project Properties: Installation Settings: Install targets to: Default Location; Deploy installed binaries is enabled, to /usr/local and Perform deployment as root is also enabled.

    But I cannot find the files on my Raspberry Pi under /usr/local:

    What am I missing?





    Thanks for the very detailed problem description. We have investigated the issue and found out that VisualGDB was ignoring the “deploy as root” option for some cases.

    We have fixed it in the following build: VisualGDB-

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.