Custom build steps on CMake projects

Sysprogs forums Forums VisualGDB Custom build steps on CMake projects

This topic contains 3 replies, has 2 voices, and was last updated by  support 1 month, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #30005

    bernardofca
    Participant

    It seems that on CMake projects, we have lost the ability to specify different Custom build steps for the different configurations. For example, we used to run some file processing only in Release mode but with our latest CMake project, the custom steps seem to be shared between all the different project configuration. Is that a know issue?

    • This topic was modified 1 month, 3 weeks ago by  bernardofca.
    • This topic was modified 1 month, 3 weeks ago by  bernardofca.
    #30011

    support
    Keymaster

    Hi,

    This is correct. The Advanced CMake Project Subsystem reuses the same set of settings for multiple targets and configurations, so the custom action lists will run for all configurations.

    To make it easier to support your scenario, we have added a “condition” parameter to the “Reference a reusable action list” action. E.g. you can set it to “$(Configuration)” = “Debug” to only run the reference list when building/debugging the Debug configuration.

    Please try this build: VisualGDB-5.6.1.4033.msi

    #30017

    bernardofca
    Participant

    Works well (once I understood how to create a reusable action list!) – Thanks a lot

    Hopefully CMake is here to stay since this is our 3rd project migration!

    #30039

    support
    Keymaster

    No worries. CMake has several advantages to any other build system we are aware of, and is actively maintained, so we wouldn’t expect it to disappear anytime soon.

    On the VisualGDB side, it is now the main and the recommended build system for embedded projects because because of the great separation of project-level, target-level and platform-level settings it offers.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.