cmake install

Sysprogs forums Forums VisualGDB cmake install

This topic contains 3 replies, has 2 voices, and was last updated by  support 4 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #32034

    paulh001
    Participant

    I develop for rapberry pi bulsseye and want to use cmake. If I add a specific path to the installation settings in the Project properties settings It does not add a install command in the CMakeList.txt.  Is there a way to do so, or is it a bug?

    #32036

    support
    Keymaster

    Unfortunately, it is hard to suggest anything specific based on the description you provided.
    In order for us to provide any help with this, please describe what you are trying to achieve vs. what you are observing using the 3-step format per our problem reporting guidelines.

    Please make sure you include all relevant uncropped screenshots so that we could help you locate the relevant settings.

    #32042

    paulh001
    Participant

    I hace resolved it manualy. But the steps are:

     

    1. In a CMake project op Menu Project->VisualGDB Project Properties
    2. Click CMake Build Settings
    3. In Installation Settings click Explicit location
    4. Fill Custom installation location: /home/pi
    5. Click Apply and Close
    6. Open CMakeList.txt

    Expectation is that CMakeLists.txt has a entry install(TARGETS applicationname DESTINATION /home/pi)

    This does not happen.

     

     

     

    #32043

    support
    Keymaster

    Hi,

    This is by design. The “installation prefix” setting affects the entire project by passing the CMAKE_INSTALL_PREFIX parameter to CMake via command line. It does not affect the contents of CMakeLists.txt.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.