CLI works, smarTTY only fails for 1 host.

Sysprogs forums Forums Other tools & products CLI works, smarTTY only fails for 1 host.

This topic contains 0 replies, has 1 voice, and was last updated by  deepz 2 weeks, 4 days ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #33173

    deepz
    Participant

    For some time I’ve been using SmarTTY without any issues.

    I have a dozen of connections that use the same PEM file, all of which work flawlessly.
    They are all hosted on AWS, and created for the same PEM file.

    And they all work flawlessly, except for one.
    There’s just 1 connection which is an exception.

    • I can connect to it from the CLI
    • I cannot connect to it with smarTTY

    I can connect to it with the most simple command:

    ssh -i myfile.pem ubuntu@hostname

    However, I cannot do the same with SmarTTY.
    I select Authentication method “OpenSSH key” (just as I do for other connections),
    I select the same pem file (same file location, same file).
    But when I connect it says: “Cannot authenticate using OpenSSH key. Enter password instead?”.

    So, it works in the commandline, and doesn’t work in SmarTTY.
    And I have no clue why.

    Which makes me wonder if there is a log file that could reveal more?

    Furthermore I modified the access privileges to the pem file, to only be accessible by the owner of the file.
    I run both the CLI and SmarTTY as administrator. Maybe worth mentioning.

    I tried everything to the point:
    I can literally open a working connection of a different server, change the hostname to the new server, and it doesn’t work.
    While it works perfectly fine from the command-line, and it’s the same PEM file.

     

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.