Clang "IntelliSense" settings?

Sysprogs forums Forums VisualGDB Clang "IntelliSense" settings?

This topic contains 6 replies, has 3 voices, and was last updated by  support 1 week, 6 days ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #9766

    tinkerer
    Participant

    When I open VisualGDB project properties and go to the tab “IntelliSense Settings”, well, there aren’t really any settings other than the choice of the engine.
    Is there a way to set up the clang “intellisense”? Some of the things it does are rather irritating. The pure VS intellisense for the embedded C project isn’t working too great, obviously, so just turning it off is also not such a nice solution.

    – tinker

    #9770

    support
    Keymaster

    Hi,

    You can tweak the Clang IntelliSense behavior by adding Clang-friendly command-line flags to “Additional flags for C/C++ files” fields on that page (e.g. -DSOME_MACRO). The IntelliSense is actually using Clang, so all Clang flags that are relevant for source parsing should be supported. If you are looking for a specific setting, let us know and we will suggest a flag that controls it.

    #9795

    tinkerer
    Participant

    Hey, yeah one example that I remember right off the bat is – I have a dark background theme in VS. And if the cursor is placed over e.g. a variable, the clang thing will highlight its entire background “blocks” very harshly, so bright that I cannot see where I’m navigating with the cursor anymore. Either severely reducing the intensity of that highlight, or disabling it (as it’s almost pointless) would be one thing that reduces irritation 😉

    #9799

    support
    Keymaster

    Hi,

    This is actually configurable globally via Tools->Options->Fonts and Colors->Text Editor (another bunch of options is under Tools->Options->Text Editor->C/C++ (VisualGDB)).

    The highlighting colors should be managed normally by VS though, so if you believe they are broken, please attach a screenshot so that we could suggest how to fix this.

    #30419

    andyjt
    Participant

    This is too annoying for words.

    Please tell me how to get rid of these daft light bulb moments

    Attachments:
    You must be logged in to view attached files.
    #30421

    andyjt
    Participant

    If anyone else gets the annoying grey text on grey background in Dark Mode, I found the setting for it (see attached)

    Change the Background to something other than Default

    I’d still like to know how to turn this off though. ALT+Enter or CTRL+. is there if you really want it

    Attachments:
    You must be logged in to view attached files.
    #30423

    support
    Keymaster

    Hi,

    You can achieve this by setting Tools->Options->Text Editor->C/C++(VisualGDB)->Other->Max. change-driven tags to 0. See this page for a comprehensive list of VisualGDB settings.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.