Can’t watch the CPU register value during the debugging

Sysprogs forums Forums VisualDDK/VirtualKD discussion Can’t watch the CPU register value during the debugging

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #637

    Hello guys..

    I’m using Windows 8.1 Pro x64 as main operating system on my real PC.
    Also I’m debugging Windows 7 x64 kernel(1G RAM, 2VCPU) on VMware 10.0 with WinDBG 6.2.9200.16384 (x64).

    You guys already know that debugging the kernel without VirtualKD is too slow and horrible.
    So I’ve been using VirtualKD 2.8 which is the latest version now for several months.

    The issue that I have while I’m debugging the kernel with VirtualKD 2.8, I can’t watch the register value through the WinDBG’s register window.
    I already know that I can watch it through the command window by typing ‘r’ command, but I just would like to watch realtime-updated register value during the debugging, because typing ‘r’ command is sometimes annoying.
    So I’ve tried to figure it out through the google, but can’t find any issue about it.

    Is there anybody who has same issue like this situation?



    I can confirm this issue on Windows 7 x64 (host) using WinDBG 6.2.9200.16384 (x64). also tried 6.3.9431.0, Win 8.1 debugging tools with same result.
    However WinDBG 6.12.0002.633 (x64) works so it must be some incompatibility between newer WinDBG and VirtualKD.


    It could be.

    I also saw that there might be internal problems in newer version WinDBG even without using VirtualKD.
    Somebody said that with using newer version WinDBG, they couldn’t watch register window.
    But with old version, they could watch it.



    I’m sad to report that even the release version of the all new and shiny Windows Debugging Tools 8.1 (windbg version 6.3.9600.16384) have this issue 😳

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.