Can't debug STM32 with J-link

Sysprogs forums Forums VisualGDB Can't debug STM32 with J-link

This topic contains 2 replies, has 2 voices, and was last updated by  mattia 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #12604

    mattia
    Participant

    Hello,

    I’m evaluating the VisualGDB IDE. I have a J-link that correctly debug on Atollic, Keil and Segger Ide, however in visualGDB it can’t connect. It appears to try to listen to the wrong port, not the classic GDB Server Listening port: 2331, but always other ports.

    Is there a way to force VisualGDB to use always port 2331?

    Thank you,

    Mattia Berton

    #12608

    support
    Keymaster

    Hi,

    VisualGDB uses randomized ports for J-Link and OpenOCD in order to support multiple debugging sessions at once. Normally it should choose a port randomly and configure both gdb stub and gdb to use it. Perhaps your firewall is interfering with it? If this is the case, please try adding JLinkGDBServerCL.exe to the list of exceptions.

    If not, please check the command line used by VisualGDB to run segger gdb server (shown in the corresponding window in VS) and the ‘target’ command in the gdb session window. If the port numbers there don’t match, please let us know. If they do, please try running the same commands manually and see if it works and if there could be any other components (e.g. antivirus) blocking the connection.

    #12621

    mattia
    Participant

    Hello,

    I solved the problem by updating the J-link software. Perhaps what you did worked for me, but I can’t verify. Thank you the same for the support.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.