Cannot step-in the kernel souce

Sysprogs forums Forums VisualKernel Cannot step-in the kernel souce

This topic contains 1 reply, has 2 voices, and was last updated by  support 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #28764

    vincent555
    Participant

    Hello,

    I just setup a debugee virtual machine with Debian buster 10.4 to debug the simple Hello-Word module.

    I used the automatic options to download and install the resources. All the sources, symbols and headers are successful imported in the Windows-PC. After I connected the Windows-PC to Debian with vmware-stub

    When I try to step-in the printk() it’s opened the view “Source Not Available”, but the sources are present in “C:\KernelCache\4.19.0-9-amd64_0.kernel\source”.

    Then I open the disassembly view and I see the symbols. I noted the path for the sources is a bit weird, there is a point in the middle (see attached screenshot). Maybe this the problem?

    • This topic was modified 3 months ago by  vincent555.
    • This topic was modified 3 months ago by  vincent555.
    • This topic was modified 3 months ago by  vincent555.
    Attachments:
    You must be logged in to view attached files.
    #28769

    support
    Keymaster

    Hi,

    It looks like the anti-tampering logic of VisualKernel has engaged and is preventing parts of it from being initialized correctly.

    Please make sure you do not change any registry keys related to VisualKernel and do not modify its components.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.