Building VisualGDB project with MSBuild

Sysprogs forums Forums VisualGDB Building VisualGDB project with MSBuild

This topic contains 4 replies, has 3 voices, and was last updated by  support 1 day, 13 hours ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #30685

    rico227
    Participant

    I get an error ‘MSB8020: The build tools for Visual Studio 2010 (Platform Toolset = ‘v100’) cannot be found. To build using the v100 build tools, please install Visual Studio 2010 build tools. Alternatively, you may upgrade to the current Visual Studio tools by selecting the Project menu or right-click the solution, and then selecting “Retarget solution”’ if I try to MSBuild <my project name>.vcxproj on a machine without VisualGDB. The goal is to build the project with MSBuild in a docker container. The project is a VisualGDB project, but technically I should be able to build the project without VisualGDB. Shouldn’t I? The error is strange to me because the project was not setup to use VS built tools 2010. Neither in an Visual Studio with VisualGDB extension nor in Visual Studio without the extension I have an option to set platform toolset to a newer version.

    #30686

    support
    Keymaster

    Hi,

    Building MSBuild-based VisualGDB projects does require VisualGDB, since it provides the actual build rules for them (see this page). However, you can easily dump the build steps for your project into a batch file (see this page), check it into the source control, and run it on the build server. You will need to patch the batch file and the .rsp files it to replace the absolute paths with proper variables, but it should be a good starting point anyway.

    If generating the .bat files is not an option, you would nee to make sure that the build server has the same Visual Studio configuration as the development machine (including MSBuild toolsets, etc.). You may also be able to get it working with a smaller MSBuild installation, although you would need to manually track down the error messages (they usually show the .props/.targets file where the error happens) and adjust the project accordingly (e.g. define some variables that the stand-alone installation expects). Generally, this is something to do at your own risk – using the batch files or getting a full VS installation should work much more reliably.

    #30710

    hf
    Participant

    Hi,

    i have the same issues but i’m not able to set the local build.

    I got this configurations window at the latest visual studio 2019 and visualgdb.

    Where is now the option hidden? Has dies changes with the lastet cmake Changes? I would also build the project from a build server (in my case gitlab) with a local runner.

     

    Best regards

     

    Holger

     

     

    • This reply was modified 1 day, 19 hours ago by  hf.
    Attachments:
    You must be logged in to view attached files.
    #30713

    hf
    Participant

    Using build with visualgdb /build

    will result in a

    “Your Makefile will nbot be auto-updated. Please go to VisualGDOProject Properties and click ‘repair command lines”

    Currently is it really not possible to checkout by server and build is automatically?! also to generate the make files by cmake by itself? That would be a big pain.

     

    Best regards

     

    Holger

    #30714

    support
    Keymaster

    Hi,

    It looks like your support period has expired a while ago. Please kindly renew it here and update to the latest VisualGDB build (VisualGDB-5.6.1.4153.msi). If the option still doesn’t show, please send us a screenshot of the settings window where you would expect the option to be, and we will help you troubleshoot it.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.