build in custom directory . bug??

Sysprogs forums Forums VisualGDB build in custom directory . bug??

This topic contains 2 replies, has 2 voices, and was last updated by  amigo421 2 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #10041

    amigo421
    Participant

    just faced with another issue,

    create limux .so makefile project from scratch with a default settings and try to build from VS.

    successfully.

    however when I tried to change a couple of them I faced with an issues:

    1. if I’m going to change remote folder from default , I was getting a errors in cases:
      – when I’m specifying absolute path, e.g. /home/myself/worspace/project
      – in cases like ~/workspace/project, I don’t have a error however it was placed into /home/myself/~/worksapce/project
      so when I’ve finally set “workspace/project” , it has been placeed into desired folder
      it means that if I select a folder from GUI , i won’t work
    2. default value for binary (DEBUG config) folder is “Debug”. for some reasons , I’ve tried to remove this for a placing .so into the same folder as a sources. got the error again

    1>VisualGDB: Sending 1 updated source file to build machine…
    1>VisualGDB: Run “make CONFIG=Debug” in directory “workspace/zeph” on …. (SSH)
    1>c:\dev\workspace\php\zeph\Makefile(35): error : Invalid configuration, please check your inputs. Stop.
    1>————————————————————-
    1>Command exited with code 2
    1>Executable: make
    1>Arguments: CONFIG=Debug
    1>Directory: workspace/zeph
    1>VisualGDB : error : Command-line action failed
    1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets(43,5): error MSB3073: exit from command “”C:\Program Files (x86)\Sysprogs\VisualGDB\\VisualGDB.exe” /build “c:\dev\workspace\php\zeph\zeph.vcxproj” “/solution:c:\dev\workspace\php\zeph\zeph.sln” “/config:Debug” “/platform:Win32″” with code 1.

    • This topic was modified 2 months, 2 weeks ago by  amigo421.
    #10048

    support
    Keymaster

    Hi,

    The “~/workspace/project” syntax is not supported by all Linux tools, so it won’t work properly. The “workspace/project” path is a relative path that can cause unpredictable behavior if specified as a project path. Please specify the full absolute path (i.e. /home/myself/worspace/project).

    #10050

    amigo421
    Participant

    you are right, thank you, it really works,

    placing .so into source folder does also work , just have needed to replace Debug with Linux-style “.”(current folder,  instead of “”

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.