Build error "_FPU_PRESENT: No such file or directory"

Sysprogs forums Forums VisualGDB Build error "_FPU_PRESENT: No such file or directory"

This topic contains 9 replies, has 2 voices, and was last updated by  GeneM 1 month, 1 week ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #26865

    GeneM
    Participant

    I’m trying to import a .uvoptx project and am getting this error when I build the solution.

    Error __FPU_PRESENT: No such file or directory EmbeddedProject2 C:\Users\gene\source\repos\EmbeddedProject2\EmbeddedProject2\arm-none-eabi-gcc.exe 1 Build

    I checked the forum but didn’t find anything.  I’m pretty new to VisualGDB and am not sure what to do next. Any advice will be appreciated.

    Thanks – Gene

     

    #26866

    support
    Keymaster

    Hi,

    It looks like a preprocessor macro got incorrectly converted into a source or an include file.

    Most likely, our importer plugin is not handling some combination of settings correctly. If you could send us the original project file you are trying to import (.uvproj + .uvopt files), we should be able to investigate and fix this.

    #26867

    GeneM
    Participant

    Here they are.

    #26868

    support
    Keymaster

    Sorry, they didn’t get attached properly. Could you please try zipping them?

    #26869

    GeneM
    Participant

    That didn’t seem to work, hopefully this will

    Attachments:
    You must be logged in to view attached files.
    #26871

    GeneM
    Participant

    By the way, that project is an example from the QP framework.  QP is an incredibly effective and well written framework for state machine based embedded apps.  It may be something you may be interested in supporting with VisualGDB.  Here’s the website: https://www.state-machine.com/

    #26872

    support
    Keymaster

    Hi,

    Strange, we have tried importing the project, but could not reproduce the issue. The _FPU_PRESENT macro was successfully imported as a preprocessor macro, so it is hard to say why it would not work on your side.

    If the entire project is not confidential, please consider sending it to us as well. If it is, please follow the steps below to gather the required information on your side:

    1. Try importing it as an MSBuild-based project (ensure you use VisualGDB 5.5 Preview 2) and build it.
    2. The error window will show the specific .cpp file that is triggering the error. Make sure you can locate this file in Solution Explorer.
    3. Locate the .rsp file corresponding to the .cpp file in the VisualGDB\Debug subfolder. It will contain the command line passed to gcc by VisualGDB.
    4. Run the following command line from the project’s directory: <full path to arm-none-eabi-gcc.exe> @VisualGDB\Debug\<rsp file> and confirm that the error can be reproduced.
    5. Send us the .vcxproj file, the .rsp file and the exact error message produced by gcc and we should be able to find the root cause and fix the importing logic accordingly.

    P.S. Based on a quick look, QP looks like a great, although very niche framework. Hence it would only be relevant for a small fraction of VisualGDB users and fully integrating it with VisualGDB would have a much lower priority than many other queued features. That said, we can always do it as a custom paid feature if anyone is willing to cover the integration costs directly. Feel free to reach out to our sales to get a quote.

    #26873

    GeneM
    Participant

    I’ve been trying a different path.  I built the basic VSgdb blinky program and am adding the QP features one at a time.  I’m still working on it but so far so good.  I do have one confusing issues.  I’m building up a QP folder inside my main project directory that will eventually have all the QP files I need for the app.  So far I’ve put all the header files in there that I need to get the app to compile without errors.  When I add the QP folder path to the Project Properties>Configuration Properties>C/C++>General/ Additional Include Directories option, everything compiles fine.  When I add the QP folder to the Solution Explorer>Header Files folder and remove the path in the Additional Include Directories I get lots of of errors; as if the compiler didn’t see any of the files in the QP folder in the Solution Explorer.  Seems like it would be nice to have all the QP .h, .hpp and .cpp files visible in the Solution Explorer.  What do I have to do to make a folder I added to the Header Files folder visible to the compiler.  I attached a .zip file of the project minus the very large .vs and VisualGDB folders.

    • This reply was modified 1 month, 1 week ago by  GeneM.
    • This reply was modified 1 month, 1 week ago by  GeneM.
    Attachments:
    You must be logged in to view attached files.
    #26877

    support
    Keymaster

    This is actually by design. Most IDEs (including Visual Studio) require the include search paths to be specified explicitly (deriving them implicitly tends to cause very hard-to-track errors if you have multiple headers with the same name in different directories).

    Adding headers to Solution Explorer will normally not affect the build at all – the only reason for adding them is to make them easily accessible via Solution Explorer.

    That said, for MSBuild-based projects you can enable automatic include path computation based on header files in Solution Explorer (VS Project Properties -> General -> Header Search Paths -> Compute Include Paths Automatically), although we would not recommend using this option in production code to avoid confusing headers with the same name.

    #26878

    GeneM
    Participant

    Great, that explains a lot.  And BTW, I’ve been able to build up the app for scratch with a lot more success.  Now I have to figure out how to replace the standard VisualGDB and STM32 SysTic_handler with the QP framework one.  I’m still working on that but I do have another question that I’ll ask in a new post.

    Thanks for the help

     

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.