Autocomplete not working

Sysprogs forums Forums VisualGDB Autocomplete not working

This topic contains 7 replies, has 2 voices, and was last updated by  support 9 months, 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #13340

    ChangedDaily
    Participant

    Hi,

     

    I have replaced the hard drive in my PC and since re-installing everything autocomplete no longer works for VisualGDB projects.

    I have created a default project for the nRF52 but the autocomplete does not work unless I switch to ‘native visual studio intellisense engine’ but this then highlights 50% of the code with errors.

    Might I have missed some installation step or setting?

    Patrick

    #13347

    support
    Keymaster

    Hi,

    This could be caused by several different issues. Please check if the project can be built successfully. If not, please try creating a new project via VisualGDB Project Wizard and it will automatically get all the dependencies. If the build succeeds, but IntelliSense doesn’t work, please attach a screenshot of the entire Visual Studio window here and we can check for common problems.

    #13428

    ChangedDaily
    Participant

    Hi,

    I have been working on several projects now and autocomplete is not working in any of them. They all build.

    What exactly do you mean by the entire Visual Studio Window?

     

    Thanks

     

    #13431

    support
    Keymaster

    Hi,

    Thanks for the update. We would definitely need to see the screenshots to advise you further. By “Entire Visual Studio Window” we mean the physical window created by Visual Studio (including the navigation bar, Solution Explorer and Errors pane). Those panes may contain clues to  the problem and we would need to see them to understand which parts of the IntelliSense engine have been initialized properly.

    #13436

    ChangedDaily
    Participant

    Hi, there is no error as such, it’s just that no suggestions are made as I start typing.

     

    I have attached a screen shot to get started…

     

    Thanks

     

    Attachments:
    You must be logged in to view attached files.
    #13467

    support
    Keymaster

    Hi,

    Unfortunately as you have cropped the screenshot, hiding the navigation bar, we are not able to tell whether the Clang engine is properly attached to the source file. Please attach a screenshot of the entire VS window as requested above.

    Also if the manual auto-completion (triggered by Ctrl+Space) works, but the automatic one doesn’t, please try clicking the lightning symbol in the auto-completion popup to enable the automatic mode.

    #13475

    ChangedDaily
    Participant

    Ha! Ctrl+space works, and then clicking the lightning symbol has enabled suggestions as I type.

    I’m sorted now thanks, but I wonder where I would have found that keyboard shortcut?

    #13493

    support
    Keymaster

    Hi,

    The shortcut actually comes from Visual Studio.  You can see under in Edit->IntelliSense together with a other IntelliSense commands. If you are not familiar with Visual Studio commands and shortcuts, we would advise looking through the Edit menu – it contains a few very powerful commands.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.