Add include files wizard not working

Sysprogs forums Forums VisualGDB Add include files wizard not working

This topic contains 1 reply, has 2 voices, and was last updated by  support 2 weeks, 3 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #30274

    dave93cab
    Participant

    I can’t seem to make vgdb pick up any files outside of the main Src and Inc files in an STM32CubeMX project. Below is my tree (removed the built-in/default folder contents).

    Build is 5.6.beta1.4073

    Main thing is the library in {Project}/Usr/lib/src and inc.

    If i add #includes for the header files I get the banner as expected with “Found 1 additional include directory required by the current file. If I click through and “add selected directories to the following target” the wizard closes but the banner remains, and I cannot build my project.

    Error nrf24l01.h: No such file or directory

    I noticed that every time I run the wizard I get an addition to CMakeLists.txt. Below is the result after running the wizard 3 times with inc folder listed 3 times.

    Setting in vgdb settings “Automatically Find Header Files..” doesn’t seem to have any effect wither.
    <h3>CMakeLists.txt</h3>

    <h3>Folder tree:</h3>

    • This topic was modified 2 weeks, 5 days ago by  dave93cab. Reason: build
    • This topic was modified 2 weeks, 5 days ago by  dave93cab.
    Attachments:
    You must be logged in to view attached files.
    #30293

    support
    Keymaster

    Hi,

    This likely happens because the header file is referenced by one of the source files inside the BSP (i.e. imported from the STM32CubeMX template) and not inside the application itself.

    Please try selecting the BSP instead of the application when adding the discovered include directories to the project settings. If adding the directories to BSP doesn’t work, please try this build: VisualGDB-5.6.1.4079.msi

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.