Analyze performance – Debugging Failed – gdbserver exited with code 1

Sysprogs forums Forums VisualGDB Analyze performance – Debugging Failed – gdbserver exited with code 1

This topic contains 18 replies, has 3 voices, and was last updated by  support 1 month ago.

Viewing 4 posts - 16 through 19 (of 19 total)
  • Author
    Posts
  • #21936

    peteras17
    Participant

    Okay, I’ve been able to get the diagnostics log for what’s happening. Here it is.

    Executing commands of lines 5, 7, 9 and 11 can be run successfully on SSH manually (they wait for something, as the command itself hasn’t exited)

    Executing command from line 12 shows Valgrind’s log runs successfully and gives this output.

    Executing command of line 16 returns the path to vgdb.

    Executing command of line 18 runs successfully, even though it exits with code 1 if launched with the Debug on Visual Studio. It shows “listening on port 2000 …” on screen.

    After this, I’m not sure how to proceed. Is there any way to start the process that is needed for it to start outputting something?

    #21962

    support
    Keymaster

    Hi,

    No problem. If the valgrind’s vgdb tool works without any problems when launched manually, it could be caused by different timing.

    Please try this build: http://sysprogs.com/files/tmp/VisualGDB-5.4.4.2436.msi

    We have added a new option: Tools->Options->VisualGDB->General->Profiling->Delay before starting valgrind’s vgdb tool

    Please try setting it to 5000 and check if this solves the problem. If yes, try reducing it to 500-1000. If not, please increase it to 60000 and open VisualGDB Diagnostics Console. VisualGDB will show the exact command line it is about to launch before it starts waiting. Please try running the command line manually from an SSH terminal and check if it also results in an error. This should help understand whether vgdb or valgrind itself (launched before) is behaving differently in VisualGDB vs. manual SSH console.

    #22013

    peteras17
    Participant

    Hello there,

    Setting it to 5000 seems to solve the problem of “GDBSERVER exited with code 1”, but Valgrind is still not testing anything in the project!

    P.S.: I can set the value as low as 1000

    #22015

    support
    Keymaster

    Hi,

    It looks like valgrind is running the memory leak detector instead of the profiling module. Could you please recheck whether valgrind works on a clean project? If yes, please try checking the differences between the VisualGDB settings for the 2 projects.

Viewing 4 posts - 16 through 19 (of 19 total)

You must be logged in to reply to this topic.